注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

天涯的博客

如果你是我眼中的一滴泪,那我永远也不会哭!

 
 
 

日志

 
 
 
 

JBoss AS 5与JDK版本支持问题  

2010-01-20 19:52:20|  分类: Java web开发 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

从JBoss 5开始提供两种不同的应用服务器分发版本。比如,你可以下载jboss-5.1.0.GA.zip,该版本使用jdk5编译,可以运行在jdk5、jdk6上,也可以直接下载使用jdk6编译且只能运行在jdk6上面的jboss-5.1.0.GA-jdk6.zip,两个版本下载地址如下:
       1. jboss-5.1.0.GA.zip:
http://sourceforge.net/projects/jboss/files/JBoss/JBoss-5.1.0.GA/jboss-5.1.0.GA.zip/download

2. jboss-5.1.0.GA-jdk6.zip:

http://sourceforge.net/projects/jboss/files/JBoss/JBoss-5.1.0.GA/jboss-5.1.0.GA-jdk6.zip/download

Sun的JDK5在即将到来的10月底以后将不再提供服务支持(不过对于付费用户仍会支持一段时间),JDK5从2004年release发展到现在已经经过了5年多时间,已经到了版本生命周期的结尾,不过JDK5仍可以通过Sun官网下载到,目前70%的下载主要是JDK6,JBoss过段时间有可能会仅仅推出支持JDK6的版本,不过目前还没有最终定下结论,主要还是得看用户的反馈。不过有一点可以肯定的是,后续推出的JBoss AS即使有支持jdk5编译的版本,不过官方也不会提供支持。

jdk版本的升级对绝大多数应用来说应该是没有什么影响的,毕竟jdk也是向下兼容的,尤其是jdk5到jdk6的升级,当然对于一些仍使用jdk1.4甚至更老版本的用户来说有可能需要应用程序做些改动(毕竟jdk1.4跟jdk5之间差别还是很大的)。

所以如果可能的话,还是尽量使用jdk5以后的版本以便于以后应用的移植,不关是JBoss应用服务器升级,移植到其它应用服务器也是一样会存在jdk版本的问题。

  评论这张
 
阅读(1599)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017